User Tag List

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: DataStore Plus "step by step" setup in FactoryTalk ViewStudio

  1. #11
    Administrator Shawn Tierney's Avatar
    Join Date
    Sep 2016
    Location
    Berkshires, MA
    Posts
    2,228
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    11
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts
    Good morning Carissa,

    Sorry I missed your post. I'm sure at this point you've probably found your answers, but for those who come after here's some food for thought:

    1) I've never run into an issue "copying" a CSV file that was actively being written to, and that is what I would suggest you do in your script - copy not move the csv log files to the USB Memory Stick.

    I also add "echo" text to my autorun scripts to let the operator know when the process has started, as well as when it's done to "count to ten" before removing the memory card with the script on it.

    2) The average USB Memory Stick can hold hundreds of thousands of average CSV files. That said, to know for sure if yours will fit, you'll want to log the average amount of data over an average time, and then multiply the resulting file size by the number you need to store on your memory card to determine how big it needs to be.

    Hope this helps,

    Shawn Tierney,
    Instructor at The Automation School
    Looking for affordable automation training? If you are, check out my courses at TheAutomationSchool.com!

  2. #12
    Member forqnc's Avatar
    Join Date
    Mar 2019
    Location
    Elizabeth City, NC
    Posts
    3
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts

    Additional Note

    Hi Shawn,
    I really like your instructions and tutorials.
    I recently went through your PVP course and found it very useful in helping me get a project going.
    I would just like to add, to this ActiveX guide, that when making your RemoteDisplayTag make sure it is in a folder and not the root directory.
    I just spent 2 hours trying to get the above working, and kept getting a grey "No Screen Selected", on bootup.
    A light bulb suddenly came on, back to one of your PVP lessons, about not making tags in the root directory.
    Just wanted to add this in case someone else has issues.

  3. The Following User Says Thank You to forqnc For This Useful Post:

    Shawn Tierney (03-29-2019)

  4. #13
    Administrator Shawn Tierney's Avatar
    Join Date
    Sep 2016
    Location
    Berkshires, MA
    Posts
    2,228
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    11
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts
    Good afternoon @forqnc,

    Thanks for your comments!

    Which PanelView Plus and ViewStudio version were you using - I'd like to try and replicate the issue here?

    Thanks either way in advance,

    Shawn Tierney,
    Instructor at The Automation School
    Looking for affordable automation training? If you are, check out my courses at TheAutomationSchool.com!

  5. #14
    Member forqnc's Avatar
    Join Date
    Mar 2019
    Location
    Elizabeth City, NC
    Posts
    3
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts
    Hi Shawn,
    HMI is a 2711P-T7C21D8S running version 9
    FactoryTalk View Studio I am using is version 10.
    Currently I am creating my .mer file to version 9 to work on the HMI.
    Even though we bought them 2 months ago, the HMI may have sat on a shelf for a while.

  6. The Following User Says Thank You to forqnc For This Useful Post:

    Shawn Tierney (03-29-2019)

  7. #15
    Administrator Shawn Tierney's Avatar
    Join Date
    Sep 2016
    Location
    Berkshires, MA
    Posts
    2,228
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    11
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts
    Thanks @forqnc
    Looking for affordable automation training? If you are, check out my courses at TheAutomationSchool.com!

  8. #16
    Member Arvind's Avatar
    Join Date
    Mar 2019
    Posts
    2
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    2711PC-T6C20D8 for data logging

    Hello Shawn ...
    This is my first time trying to log excel reports from a panelview HMI . After following the step by step guide , I can see .csv files being created in the designated folder when I test run the project with Factory Talk View ME Station emulator . But when I download and run the project in my Panel View Plus Compact 600 HMI - no files are generated . The cat no for HMI is 2711PC-T6C20D8 and the firmware virsion is 8.0.8 . I dont understand what I am missing , please help .
    Thanks and regards ,
    Arvind

  9. #17
    Member BB32152's Avatar
    Join Date
    Mar 2019
    Posts
    3
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Active X Data Store Plus csv file issue

    I have created an Active X Data Store Plus app with Factory Talk View ME v10.0., Using a CompactLogix L33 processor running Studio v31.11.

    The csv file downloads to a USB.
    The file contains 5 Barcodes which are scanned from a Keyence Barcode scanner. The issue is this:

    The scanner scans the barcode and the correct barcode is read in the PLC and displayed on the HMI. However, if an barcode ends in a negative digit
    ( 1,3,5,7,9),the data in the csv file drops the negative digit and records it as the next lesser even digit. (0,2,4,6,8)
    Ex Barcode 23198077 reads 23198077 in the PLC and HMI but is recorded as 23198076 in the csv file. All barcodes that end in an even number reads and downloads correctly. Rockwell Tech support is working on the issue

    Any help is greatly appreciated

    Copy of a scan rung is attached

    Thanks
    BB32152
    Attached Images Attached Images

  10. #18
    Administrator Shawn Tierney's Avatar
    Join Date
    Sep 2016
    Location
    Berkshires, MA
    Posts
    2,228
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    11
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts
    Good afternoon @Arvind,

    What do you have the designated folder / path set to?

    Once you are done testing on your PC, you need to set the path to something compatible with a PVPlus...

    Sincerely,

    Shawn Tierney,
    Instructor at The Automation School
    Looking for affordable automation training? If you are, check out my courses at TheAutomationSchool.com!

  11. #19
    Administrator Shawn Tierney's Avatar
    Join Date
    Sep 2016
    Location
    Berkshires, MA
    Posts
    2,228
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    11
    Thanks Thanks Received 
    2
    Thanked in
    2 Posts
    Good afternoon @BB32152,

    Sounds like you might have found a bug?

    Have you tried logging your barcode to CSV as a string instead?


    Good luck, and please let us know if you resolve your issue!

    Shawn Tierney,
    Instructor at The Automation School
    Looking for affordable automation training? If you are, check out my courses at TheAutomationSchool.com!

  12. #20
    Member Arvind's Avatar
    Join Date
    Mar 2019
    Posts
    2
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts
    Good Morning Shawn ,
    I finally got it working with the path "\temp\datalog.csv" . I think my problem was rather stupid - forgetting the closing " symbol . Managed to access the files on a computer using the FTP .
    Thanks very much for the fabulous step by step guide , I may come back with some more questions later .
    Thanks and regards ,
    Arvind

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •